Sunday, March 4, 2012

GNS3 using same 10-space


I began this lab with the intent to discover how I might include the same subnet in several places in the same network infrastructure in such a way as to not cause any conflict.

I've also included the following:

router-on-a-stick (R7)
NAT (PAT) (R1 R2)
mutiple routing protocols; RIP, OSPF and EIGRP.
2-way route redistribution from/to OSPF (R1 R2)
PPP chap authentications. (R2 R6)
Frame Relay


10.0.0.0/29 is found in the RIP domain; 10.0.0.0/30 is found in the EIGRP domain.
The core OSPF domain should not have any route to the above 10-space.

All subnets should be pingable from everywhere in this network infrastructure EXCEPT
the already mentioned 10-space.

Feel free to attempt to put this lab together in any way you see fit. Use my configs as a helper in case you get stuck. Good luck!

Cheers,
            nocleader




 
Check out R5's routing table. It shows all subnets in this network EXCEPT the 10.0.0.0./30 subnet in the EIGRP domain.





 
----------- R1 config -------------------------------------------------

hostname R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.1.1 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/0
ip address 10.0.0.1 255.255.255.248
ip nat inside
ip virtual-reassembly
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 10.0.0.2 101 broadcast
frame-relay map ip 10.0.0.3 102 broadcast
no frame-relay inverse-arp
!
interface FastEthernet0/1
ip address 10.0.1.5 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
redistribute rip subnets
network 1.1.1.1 0.0.0.0 area 0
network 10.0.1.0 0.0.0.3 area 0
network 10.0.1.4 0.0.0.3 area 0
distribute-list 10 out rip
!
router rip
version 2
redistribute ospf 1 metric 2
network 1.0.0.0
network 10.0.0.0
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source list 20 interface Loopback0 overload
!
access-list 10 deny 10.0.0.0 0.0.0.7
access-list 10 permit any
access-list 20 permit 10.0.0.0 0.0.0.7




 ----------- R2 config -------------------------------------------------


hostname R2

username R6 password 0 cisco

 interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.1.2 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.0.1 255.255.255.252
 ip nat inside
 ip virtual-reassembly
 encapsulation ppp
 clock rate 2000000
 ppp authentication chap
!
interface FastEthernet0/1
 ip address 10.0.1.9 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
router eigrp 1
 redistribute ospf 1 metric 1544 2000 255 1 1500
 network 10.0.0.0 0.0.0.3
 no auto-summary
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 redistribute eigrp 1 subnets
 network 1.1.1.1 0.0.0.0 area 0
 network 2.2.2.2 0.0.0.0 area 0
 network 10.0.1.0 0.0.0.3 area 0
 network 10.0.1.8 0.0.0.3 area 0
 distribute-list 10 out eigrp 1
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source list 20 interface Loopback0 overload
!
access-list 10 deny   10.0.0.0 0.0.0.7
access-list 10 permit any
access-list 20 permit 10.0.0.0 0.0.0.3



 ----------- R3 config -------------------------------------------------

 hostname R3
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.1.10 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.1.6 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 10.0.1.4 0.0.0.3 area 0
 network 10.0.1.8 0.0.0.3 area 0



 ----------- R4 config -------------------------------------------------

hostname R4
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.0.2 255.255.255.248
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 10.0.0.1 401 broadcast
 frame-relay map ip 10.0.0.2 401
 frame-relay map ip 10.0.0.3 401 broadcast
 no frame-relay inverse-arp
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router rip
 version 2
 network 4.0.0.0
 network 10.0.0.0
 no auto-summary



----------- R5 config -------------------------------------------------

 hostname R5
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.0.3 255.255.255.248
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 10.0.0.1 501 broadcast
 frame-relay map ip 10.0.0.2 501 broadcast
 frame-relay map ip 10.0.0.3 501
 no frame-relay inverse-arp
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router rip
 version 2
 network 5.0.0.0
 network 10.0.0.0
 no auto-summary






----------- R6 config -------------------------------------------------


hostname R6
!
username R2 password 0 cisco
!
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 67.67.67.2 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.0.2 255.255.255.252
 encapsulation ppp
 clock rate 2000000
 ppp authentication chap
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 1
 network 6.6.6.6 0.0.0.0
 network 10.0.0.0 0.0.0.3
 network 67.67.67.0 0.0.0.3
 no auto-summary



----------- R7 config -------------------------------------------------


 hostname R7
!
interface Loopback7
 ip address 7.7.7.7 255.255.255.255
!
interface FastEthernet0/0
 ip address 67.67.67.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.7
 encapsulation dot1Q 7
 ip address 67.67.68.1 255.255.255.0
!
interface FastEthernet0/1.8
 encapsulation dot1Q 8
 ip address 67.67.69.1 255.255.255.0
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 1
 network 7.7.7.7 0.0.0.0
 network 67.67.67.0 0.0.0.3
 network 67.67.68.0 0.0.0.255
 network 67.67.69.0 0.0.0.255
 no auto-summary






Saturday, February 25, 2012

GNS3 Using Cisco and Juniper


This lab is just a "getting to know Junos" lab that demonstrates OSPF route exchange between IOS and JUNOS.

The PC used for this lab is a Win7-64 with Intel i7-2600k CPU and 16 Gig of RAM.

Once GNS3 starts and the "Start all devices" icon is clicked, it takes 7 minutes for a login prompt to appear on the Junos hosts respective terminals.

The two qemu processes take about 6% of CPU each. A bit after 7 minutes, everything settles down; the PC is not at all slow after this.


 
GNS3 appears to save some info about the Junos hosts only when the hosts are stopped.  Assuming you save your work as a project ... you'll see a SWAP file in the directory of the Junos hosts with a time stamp reflecting the time you stop the host.  The configuration for the Junos boxes IS persistant; ie ... the Junos hosts under GNS3 do save their respective configurations.


 The Junos hosts use a terminal with no cut/paste so I use the console on GNS3 to fire up putty instead; its much much more flexible.


 
In any case you may prefer to save the Junos configs manually after a few changes so the configs can be pasted in later if needed.

NOTE: you can't save your config changes via "commit" command until you specify a root password so you should do that first.


------ Junos2 ----------------------
root@Junos2# show | display set
set version 10.1R1.8
set system host-name Junos2
set system root-authentication encrypted-password "xxxxxxxxxxxxxxxxxxxxxxx"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 unit 0 family inet address 10.5.5.2/30
set interfaces em4 unit 0 family inet address 10.3.3.1/30
set interfaces lo0 unit 0 family inet address 7.7.7.7/32
set protocols ospf area 0.0.0.0 interface em4.0
set protocols ospf area 0.0.0.0 interface em0.0
set protocols ospf area 0.0.0.0 interface lo0.0

------ Junos1 ----------------------
root@Junos1# show | display set
set version 10.1R1.8
set system host-name Junos1
set system root-authentication encrypted-password "xxxxxxxxxxxxxxxxxxxxxxx"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 unit 0 family inet address 10.5.5.1/30
set interfaces em4 unit 0 family inet address 10.4.4.1/30
set interfaces lo0 unit 0 family inet address 8.8.8.8/32
set protocols ospf area 0.0.0.0 interface em4.0
set protocols ospf area 0.0.0.0 interface em0.0
set protocols ospf area 0.0.0.0 interface lo0.0

------ R1 ----------------------
R1#show run
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.4.4.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.3.3.2 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!



One curious difference between the two platforms is that the "All OSPF routers" multicast address 224.0.0.5 address appears in the routing table of the Junos boxes,  but the IOS box does not have a route for it.


Cheers,
                   nocleader

 

Thursday, February 23, 2012

GNS3 Vyatta host

This lab is just a very simple demonstration of a Qemu Vyatta host.

I can't seem to reliably start/stop/save any qemu host under GNS3 for some reason so I ended up spending far more time than necessary troubleshooting this issue and I've not resolved it yet.  I'll have to try another platform other than Win7-64.

The Vyatta CLI is Junos like in its look/feel.  Remember to commit your changes.



-------------- Partial configuration Vyatta host -------------

interfaces {
    ethernet eth0 {
        address 10.0.0.1/24
        duplex auto
        hw-id 52:54:00:12:34:56
        smp_affinity auto
        speed auto
    }
    loopback lo {
        address 5.5.5.5/32
    }
}
protocols {
    ospf {
        area 0 {
            network 0.0.0.0/0
        }
    }


--------- Partial configuration CiscoRouter ----------------
 
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0







Configuration Virtual PC Simulator for dynamips:










Ping OSPF neighbor from Vyatta host:


 Ping OSPF neighbor from CiscoRouter host:


Cheers,
             nocleader





Saturday, February 18, 2012

GNS3 lab router on-a-stick

GNS3 lab router on-a-stick:

Curiously, R1 shows all CDP neighbors; the spoke routers do not show any CDP neighbor.  Debugging CDP on R1shows CDP being sent and recieved out sub-interfaces.  Debugging CDP on spoke router R2 shows CDP sends but no CDP receives.



----- Hub router R1 ---------
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.0.2.1 255.255.255.0
!
interface FastEthernet0/0.3
 encapsulation dot1Q 3
 ip address 10.0.3.1 255.255.255.0
!
interface FastEthernet0/0.4
 encapsulation dot1Q 4
 ip address 10.0.4.1 255.255.255.0
!
interface FastEthernet0/0.5
 encapsulation dot1Q 5
 ip address 10.0.5.1 255.255.255.0
!


----- Spoke router R2 ------------
!
interface FastEthernet0/0
 ip address 10.0.2.2 255.255.255.0
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0



Cheers,
                   Nocleader