GNS3 lab router on-a-stick:
Curiously, R1 shows all CDP neighbors; the spoke routers do not show any CDP neighbor. Debugging CDP on R1shows CDP being sent and recieved out sub-interfaces. Debugging CDP on spoke router R2 shows CDP sends but no CDP receives.
----- Hub router R1 ---------
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.0.2.1 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 10.0.3.1 255.255.255.0
!
interface FastEthernet0/0.4
encapsulation dot1Q 4
ip address 10.0.4.1 255.255.255.0
!
interface FastEthernet0/0.5
encapsulation dot1Q 5
ip address 10.0.5.1 255.255.255.0
!
----- Spoke router R2 ------------
!
interface FastEthernet0/0
ip address 10.0.2.2 255.255.255.0
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
Cheers,
Nocleader
Image shows sub-interface IP on R1 is 10.0.5.2/24.
ReplyDeleteCorrect IP is 10.0.5.1/24